Student Help Site
 
Web Browser/Operating System Requirements

As of January 18, 2013:

Unsupported Technologies
The following technologies are no longer supported:

  • Internet Explorer 6,7
  • Firefox 1.x,2.0,3.0,3.5, and 3.6
  • Safari 2.0, 3.x (no Safari browser is supported on Windows)
  • Mac OSX 10.3, 10.4, 10.5
  • Java 5

Supported Technologies
Supported technologies are listed in the tables below. Find the operating system that you are using and then look across the table to see what web browsers are compatible. You want to use a browser that is either 'compatible' or 'certified' (preferably certified if possible). Only operating systems listed below are supported.

IMPORTANT NOTE: If you use Firefox or Google Chrome, only use the standard browser. Don't use another version such as one labeled 'beta'. You can download the standard version of Firefox here and the standard version of Google Chrome here.


* * * * * * * * * * * * * *

Compatible Windows browsers

Mac compatible browsers